Install the Python Authentication Library

Veracode APIs

You can install the Python authentication library from the Python Package Index (PyPI) or obtain it as a container image from Docker Hub. The library enables HMAC authentication, which is a required security measure for using the Veracode APIs with your Python applications.

Before installing the Python authentication library, you must meet these prerequisites:
  • A Linux, UNIX, macOS, or Windows machine.
  • Installed Python 3.5 or later. If you need to install or upgrade Python, refer to the Python Wiki for advice on choosing a Python download.
  • Upgraded to the latest version of pip, the Python package manager. If you have a new installation of a compatible Python version, you can omit this step. Otherwise, you must upgrade pip to work with Veracode authentication libraries. You can read pip upgrade instructions on the pip website. Look for the upgrade commands in the installation documentation.
  • Generated Veracode API credentials.
  • Added your Veracode API credentials to a Veracode API credentials file.
To download and install the Python authentication library from PyPI, run this command:
pip install veracode-api-signing

You can also obtain the Python authentication library as a container image from Docker Hub.