Packaging Perl Applications

Veracode Packaging Requirements

Your Perl CGI applications must meet specific compilation requirements before you can submit them for scanning.

See Supported Languages and Platforms for instructions for other platforms.

Required Files

Veracode requires all source files for the application.

Supported Perl Versions

Language Version
Perl 5.x (CGI applications only)

Compilation and Packaging Guidance

Upload a compressed ZIP archive containing all Perl source code, maintaining the project structure, to Veracode. Do not include third-party packages.

Veracode only scans files with these extensions:

  • PL
  • PM
  • PLX
  • PL5
  • CGI